Limited set of queries impacted by Cypher 25 issue

Incident Report for Neo4j Aura

Resolved

The fix has been fully deployed to all impacted instances. This incident is now resolved.
Posted Jan 27, 2026 - 15:58 UTC

Update

We are continuing to monitor the situation at this time.
Posted Jan 27, 2026 - 14:51 UTC

Monitoring

The fix has rolled out to the affected components, we are now monitoring the situation at this time.
Posted Jan 27, 2026 - 11:10 UTC

Update

We are rolling out the fix and will update you when this is completed.
Posted Jan 27, 2026 - 09:50 UTC

Update

We have identified a solution for this issue and will be rolling out in Aura. Once the update has been deployed we will update this tatus page.
Posted Jan 27, 2026 - 01:37 UTC

Identified

We have identified an issue that may affect a limited set of Cypher 25 queries for AuraDB Free, Professional and AuraDS.

This may affect:
- Queries using the conditional query WHEN in combination with a non-grouping aggregation over null values result in an incorrect number of rows returned.
- Queries using NEXT can produce an unexpected variable not defined error in some instances.

We are actively working on a fix and will update this page as more information becomes available.
Posted Jan 26, 2026 - 19:26 UTC
This incident affected: AuraDB Professional (*.databases.neo4j.io) (AuraDB Professional on AWS (*.databases.neo4j.io), AuraDB Professional on Azure (*.databases.neo4j.io), AuraDB Professional on GCP (*.databases.neo4j.io)), AuraDS (*.databases.neo4j.io) (AuraDS on AWS (*.databases.neo4j.io), AuraDS on Azure (*.databases.neo4j.io), AuraDS on GCP (*.databases.neo4j.io)), and AuraDB Free (*.databases.neo4j.io).