Subset of MERGE queries lead to setting unexpected property values

Incident Report for Neo4j Aura

Resolved

The fix has been fully deployed to all impacted instances. This incident is now resolved.
Posted Mar 04, 2026 - 15:19 UTC

Monitoring

The fix has now been deployed to those instances impacted and we are monitoring the situation.
Posted Mar 04, 2026 - 14:07 UTC

Update

The fix is being deployed and the status page will be updated upon completion of the full deployment
Posted Mar 04, 2026 - 04:52 UTC

Update

The fix is being deployed and the status page will be updated upon completion of the full deployment of the fix.
Posted Mar 04, 2026 - 01:39 UTC

Identified

A recent update resulted in MERGE queries which referenced the same merged property on both the left and right hand side of an ON MATCH SET or ON CREATE SET clause deleting that property from the node, or setting it to an invalid value during query runtime. The node being matched against must have had at least one property uniqueness constraint present.

A fix has been identified and will be applied as soon as possible. Instances marked as "Production" are not impacted.
Posted Mar 03, 2026 - 21:35 UTC
This incident affected: AuraDB Virtual Dedicated Cloud (*.databases.neo4j.io) (AuraDB Virtual Dedicated Cloud on AWS (*.databases.neo4j.io), AuraDB Virtual Dedicated Cloud on Azure (*.databases.neo4j.io), AuraDB Virtual Dedicated Cloud on GCP (*.databases.neo4j.io)), AuraDB Professional (*.databases.neo4j.io) (AuraDB Professional on AWS (*.databases.neo4j.io), AuraDB Professional on Azure (*.databases.neo4j.io), AuraDB Professional on GCP (*.databases.neo4j.io)), AuraDS (*.databases.neo4j.io) (AuraDS on AWS (*.databases.neo4j.io), AuraDS on Azure (*.databases.neo4j.io), AuraDS on GCP (*.databases.neo4j.io)), AuraDS Enterprise (*.databases.neo4j.io) (AuraDS Enterprise on AWS (*.databases.neo4j.io), AuraDS Enterprise on Azure (*.databases.neo4j.io), AuraDS Enterprise on GCP (*.databases.neo4j.io)), AuraDB Business Critical (*.databases.neo4j.io) (AuraDB Business Critical (*.databases.neo4j.io) on AWS, AuraDB Business Critical (*.databases.neo4j.io) on Azure, AuraDB Business Critical (*.databases.neo4j.io) on GCP), and AuraDB Free (*.databases.neo4j.io).